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Introduction
The purpose of this lab is to familiarize you with the effects of global physiological
changes on the BOLD signal. It is important to be aware of such effects in fMRI
because some experimental protocols may lead to unintentional physiological
changes. An example would be a cognitive experiment in which intense
concentration or anxiety about performing the task correctly leads subjects to
change their breathing. As you will see in this lab, even a modest shift in
breathing rate can have a significant effect on the BOLD fMRI signal.
Another reason for studying BOLD responses to global physiological changes is
that this is a good way to examine regional differences in BOLD sensitivity. The
fractional change in BOLD signal for a given change in blood flow can vary in
different parts of the brain, depending on the local density of blood vessels and
the physiological state of the particular tissues at rest. It's difficult to study this
using neuronal stimulation, because there's no easy way to ensure equivalence
of the stimuli used to activate different regions. Respiratory perturbations like the
one used in this lab provide a good way to circumvent this problem, because as
global perturbations they have a simultaneous and similar effect on all parts of
the brain.
In the exercises below you will be asked to make a number of observations and
answer questions (highlighted in red). Your lab report will be the summary of
these observations and answers, so be sure to make notes and printouts as you
go.

Description of acquired data
In the exercises below you will examine the effects of a relatively modest but
sustained change in breathing on the BOLD fMRI signal. In the data acquisition
component of this lab, we acquired a number of BOLD EPI datasets including
three during which the subject underwent different combinations of breathing
change and neuronal activation:
•

•

•

visual stimulation and simultaneous right-hand movement task: in
this seven minute long scanning run, the subject was exposed to a visual
stimulus throughout the third and fourth minutes. The subject was also
instructed to perform repetitive finger tapping movements with her right
hand for the two minute period that the visual stimulus was on. During the
rest of the scan (the first two minutes and the fifth through seventh
minutes) she viewed a uniform grey screen and did not move her hand.
deep breathing, no task: in this run, also seven minutes long, the subject
did not receive visual stimulation or move her hand. Instead, she
deliberately increased the depth of her breathing for a four minute period
during the scan (the second through fifth minutes). Deep breathing lowers
the amount of carbon dioxide in the blood, which in turn lowers blood flow
throughout the brain (CO2 is a vasodilator). This scan should therefore
show us the effects of such a change in blood flow on the BOLD signal in
different parts of the brain.
visual stimulation/hand movement plus deep breathing In this run we
combined the events in the two previous scans. That is, the subject
breathed more deeply for four minutes and in the middle of this period of
hyperventillation she underwent visual stimulation and performed the hand
movement task. The purpose of this run is to see how breathing-related
effects combine with the responses to visual and motor tasks.

The timing of the conditions described above is summarized in the graph below.
The elevated portions of the blue and red plots represent the periods during
which the subject was breathing deeply and/or undergoing the visual-motor task.

There are also two BOLD EPI series which will be used for mapping projections
of the retina and right hand in the brain:
•
•

a series with a semicircular visual stimulus rotated through three cycles of
360 degrees.
a series in which the subject alternated between a right and left-hand
motor task (3 cycles of each)

These provide a robust and specific means of identifying tissue volumes
stimulated by the visual and motor inputs applied during the previous scans. We
could also have tried to generate activation maps using the visual
stimulation/hand movement scan without deep breathing, but there are two
things that make this less than ideal: 1) the visual stimulation and hand
movement periods had identical timing, complicating discrimination between
hand and motor responses, and 2) the timing of the tasks was designed around
the slow evolution of the breathing-related effects and is not optimal for response
detection. For more information on the phase-encoding approach used to identify
retinal and hand projections, see the section on retinotopy in the manual for Lab
1.
Pulse sequence details - functional scans: All BOLD functional scans
in this experiment were performed with the following parameters:

o
o
o
o
o
o
o
o
o

acquisition type: 2D echo-planar imaging (EPI)
spatial resolution = 4x4x4mm3
time needed to acquire one brain volume: approx. 1 second
repetition time (TR) = 3 seconds
echo time (TE) = 30 milliseconds
echo type: gradient-echo
flip angle = 90 degrees
image matrix size: 64x64 x 20 slices
static magnetic field = 2.9 Tesla

Also included in the lab data are a 3D T1-weighted anatomic scan and a 3D MR
angiogram (for visualizing vasculature).
Pulse sequence details - 3D T1-weighted scan: The anatomic scan
used the following parameters:
o
o
o
o
o
o
o
o
o

acquisition type: 3D Magnetization Prepared RApid Gradient
Echo (MP-RAGE)
spatial resolution = 1x1x1mm3
time needed to acquire one brain volume: 4 minutes, 30
seconds
repetition time (TR) = 11 milliseconds
echo time (TE) = 4 milliseconds
echo type: gradient echo
flip angle = 8 degrees
image matrix size: 256x256 x 160 slices
static magnetic field = 2.9 Tesla

Pulse sequence details - MR angiogram: For the magnetic resonance
angiogram, we used the following parameters:
o
o
o
o
o
o
o
o

acquisition type: 3D RF-spoiled, gradient-echo scan with
magnetization transfer preparation
spatial resolution = 0.4x0.4x0.8mm3
time needed to acquire one brain volume: 6 minutes, 44
seconds
repetition time (TR) = 35 milliseconds
echo time (TE) = 3.6 milliseconds
echo type: gradient echo
flip angle = 20 degrees
image matrix size: 512x512 x 90 slices

o

static magnetic field = 2.9 Tesla

The combination of short TR and relatively large flip angle result in inflow
enhancement of the blood. A magnetization transfer prepulse is also used
to selectively attenuate the tissue (but not the blood).
Now lets look at some of these scans. To get started, we need to initialize our
working environment. Then we'll generate the regions of interest we will need,
and apply these to the other EPI series with deep breathing and/or visual-motor
activity.

Region of interest generation
Up until now, most of the signals you've looked at have been for single voxels. As
the basic imaging unit, the voxel is important to think about. However, the signalto-noise ratio of our observations can be greatly enhanced by averaging over
multiple voxels. Note that this is only helpful to the extent that a set of voxels can
be considered equivalent in terms of their tissue makeup and sensitivity to a
particular stimulus. Such a grouping of similar voxels, averaged to enhance the
signal-to-noise ratio, is often referred to as a region of interest or ROI.

Retinal projection ROI
First, generate an F statistic map for the retinal mapping scan. This is basically a
map of the spectral power (relative to noise) in the time-series at the frequency of
a periodically modulated input stimulus:
1. open the file is-0-allegra-20002-20011003-163352-9-mri.mnc
(this contains the data needed for retinal mapping)
2. from the Tools->Statistics submenu, select F statistic for periodic
design
3. click OK
(the default parameters should be good - we skip the first 8 frames and
have three cycles of stimulus modulation over the remaining 120)
After a short wait you should see the F-statistic map in the Dview viewports. The
activated region should be at the back of the brain towards the lower (smaller z
value) edge of the volume.

What do those parameters mean in the F statistic menu? This
analysis actually produces two output volumes. Under the Select menu
the phase volume will appear with the -fftp suffix and the F-statistic (i.e.
the FFT magnitude-derived map) will have the -fftm suffix. In the case of
the alternating right-hand/left-hand task, the F statistic image will highlight
areas associated with both hands. The phase will allow us to discriminate
the left and right hand representations in cortex. In order to perform the
required spectral analyses, the following information is needed:
Excluded initial frames: [1:8] In the retinal mapping scan
we want to exclude the first eight frames because these include
bright, non-steady-state scans and also because they include the
short dummy cycle of stimulus modulation.
o
Number of periods (after excluded frames): 3 After the
excluded frames, we performed three full cycles of stimulus
modulation over the remaining 120 frames (achieved by rotating the
semicircular mask over the radial checkerboard pattern three
times). This corresponds to a modulation period of 40 frames, so
we will look at the equivalent frequency in the temporal power
spectrum to identify retinotopically organized cortex.
o
Modulus threshold (for phase computation): 0.1 This
parameter tells the software to only compute the phase in voxels in
which the F statistic is above the entered value. The F statistic map
will highlight voxels in which the temporal BOLD signal is strongly
periodic with the same frequency as the stimulus modulation. It tells
us nothing about the phase of such periodic responses, however.
The phase of the temporal power spectrum at the stimulus
modulation frequency allows different cortical locations to be
associated specifically with different polar angles in the visual field.
The problem is that the phase values in voxels that are not affected
by the stimulus will be wildly random (their distribution has no
central tendency or mean value), making it difficult to use
thresholding for ROI delineation.
o
Phase offset in radians: pi./2 This is a constant added to
the value of each voxel in the phase image, based on arbitrary
aspects of the experimental design. It can be useful to prevent
phase-wrapping of values greater than 2π back to 0 in regions
where there should really be a continuous gradient in the cortical
mapping of visual field. This has no effect on the F-statistic image.
o

The next step will be to generate an ROI based on this activation map. This is
done by automatically selecting all voxels in the volume in which the intensity
values (in this case F-statistics) are in a prescribed range. The resultant volume
of tissue will be highlighted in pink, and can be applied to other volumes acquired
in the experiment to compute the average signal within the ROI.

1. from the Tools->Region of Interest submenu, select Create ROI->by
thresholding current volume
2. Name the ROI Visual
3. enter a lower limit of 0.12
4. click OK
You should now see the ROI overlaid on the F-statistic map in pink. Now we'll
map the right-hand sensorimotor projection.
Right hand projection ROI
To map hand projections, we had our subject alternate between one minute
intervals of left or right hand movement. Because she was always moving one
hand, there should be little modulation of non-specific sensorimotor pathways. In
tissue with specific projections to the right or left hand however, there will be a
squarewave modulation of activity with a two-minute period.
Identifying the right-hand projection is a little more complicated than for the
retina, because we have both right and left hand activation in the F-statistic map.
To discriminate between the two hands, we'll make use of the phase of handrelated response waveforms. We can do this because the right and left hand
movement periods were 180 degrees out of phase with respect to each other.
1. open the file is-0-allegra-20002-20011003-163352-10-mri.mnc
(this contains the data needed for hand mapping)
2. from the Tools->Statistics submenu, select F statistic for periodic
design
3. change Modulus threshold (for phase computation) to 0.175
4. change Phase offset in radians to 0
5. click OK
(the rest of the default parameters should be good)
Again you should see an F-statistic map in Dview after a short wait. There should
be two main activation foci on the left and right sides of the brain, although you
will probably have to scroll through the brain to find them. The coronal view gives
what is probably the best depiction of the bilateral activation foci. This time we
will use the phase image to discriminate between left and right hand activity
(note: don't confuse the phase of the response waveform with transverse
magnetization phase!).
Again let's make an ROI:
1. using the Select menu, select the file is-0-allegra-20002-20011003163352-10-mri-fftp.mnc
(this is the phase of the response)

2. from the Tools->Region of Interest submenu, select Create ROI->by
thresholding current volume
3. Name the ROI Rhand
4. change the upper limit to -1.7
(the lower limit should be fine)
5. click OK
You should now see the ROI overlaid on the F-statistic map in the usual ugly
pink. Now we are ready to apply these ROI's to the other data we acquired.
ROI-based signal analysis
In the previous steps, you used functional datasets that were designed to
optimize detection power for identification of 3D tissue volumes containing retinal
and hand projections. These tissue volumes will necessarily undergo blood flow
changes during the other scans, because we have either lowered arterial CO2,
activated neurons within the ROI, or both. In this exercise we will average signals
within the retinal and right hand ROI's to look at the resultant BOLD responses.

Visually evoked response
1. open the file is-0-allegra-20002-20011003-163352-6-mri.mnc
(this contains the data during simultaneous visual and hand activation)
2. from the Tools->Region of Interest submenu, select Apply ROI to
current file and pick Visual (the ROI we created). You should see the
ROI overlaid on the EPI volume. The plotted signal will now be the
average signal within the ROI (it will no longer track the yellow cursor).
3. using the selection box in the lower right corner of the Dview window,
change the signal type from Raw signal to Percent signal
4. note the strong signal at the start of the signal (time = 0); this is due to fully
relaxed magnetization prior to application of repeated RF excitation pulses
and arrival at steady-state
5. to exclude the initial non-steady-state frames, select Tools
>Stimulation/Timing->Enter frames to exclude->as MATLAB®
expression and click OK to accept the default (the MATLAB® vector [1 2
3] tells Dview to exclude the first three frames here).
6. the visually evoked response, lasting from 120-240sec, should be clearly visible to see a depiction of the stimulation timecourse, select Tools>Stimulation/Timing->Enter design input matrix->as MATLAB® expression
and enter the following MATLAB® expression:
M = [zeros(1,40) ones(1,40) zeros(1,60)];

you should see a depiction of the stimulation time-course plotted in red
over the signal, and the average percent change will be reported.
7. make a note of the average percent change in the visual ROI during the
visual/motor task.
How does Dview compute changes during activation? By now you
should have noted that, after entering a design matrix, Dview tries to
compute percent changes during periods of activation relative to some
baseline period. Here is a brief outline of the procedure used: periods in
which the design input matrix is zero are used as the reference baseline.
Periods in which the design input matrix is one are deemed to reflect the
non-baseline condition of interest. Design matrix values that are neither
zero nor one are not used in calculating changes. Percent change is
calculated as the average signal level during activation (design = 1) minus
the average signal during baseline (design = 0), divided by the average
baseline signal level and multiplied by 100. Points that have been
excluded (flagged by green x's in plots) are never included in calculations.
When the plot mode is set to Raw signal the difference value is in raw MR
signal units - not percent.
Sensorimotor response
1. open a second instance of the file is-0-allegra-20002-20011003-1633526-mri.mnc
(you can do this by just opening the file again without closing the first
instance)
2. from the Tools->Region of Interest submenu, select Apply ROI to
current file and pick Rhand (the other ROI we created)
3. using the selection box in the lower right corner of the Dview window,
change the signal type from T signal (raw) to Percent signal
4. once again, to exclude the initial non-steady-state frames, select Tools
>Stimulation/Timing->Enter frames to exclude->as MATLAB®
expression and click OK to accept the default (this excludes the first
three frames)
5. the sensorimotor response, lasting from 120-240sec, should be clearly
visible - to see a depiction of the stimulation timecourse, use Tools
>Stimulation/Timing->Enter design input matrix/vector->as MATLAB®
expression; the expression you entered last time should now be the
default, so just click OK
6. make a note of the average percent change in the right-hand ROI during
the visual/motor task. Is it different from the response in the visual area?

Comparing the visual and sensorimotor responses When comparing
the visual and sensorimotor responses, it's important to remember that
they were evoked by quite different stimuli. The visual stimulus, a rapidly
modulated (8Hz) high-contrast radial checkerboard pattern, is quite potent
as visual stimuli go. On the other hand, the motor task performed was of
relatively low complexity. Simpler tasks and subtler sensations do not
always lead to weaker responses, but in many situations there is a
correlation (or at least a dose-response curve) between perceived
intensity and amplitude of the associated BOLD response (the relationship
between contrast of a visual stimulus and response in V1 is a good
example).
It is also worth thinking about the factors that dictate the spatial extent of
regions activated by the visual and hand tasks. The boundaries of the
visual response are determined by the area of the retina (or, equivalently,
visual field) that is stimulated. The size of the area associated with the
finger movement task is determined by the distribution of motor units in
the hand that are involved (basically how many fingers were used).
Note that we could easily arrange to have a large area of activation with
small response amplitude by exposing a large extent of the retina to a very
low contrast visual stimulus.

Responses to deep breathing
Now we'll look at the BOLD signal changes in both the visual and right-hand
ROI's produced by deep breathing (with no stimulation/activation). Remember
that deep breathing will change blood flow everywhere in the brain - including our
ROI's.
Visual ROI:
1. open the file is-0-allegra-20002-20011003-163352-8-mri.mnc
(this file contains the deep-breathing-only data)
2. change the signal type to Percent signal
3. apply the Visual ROI to this file
4. exclude the first three frames
5. enter the following design input matrix (note that it's slightly different from
the one used above for visual and sensorimotor tasks):
M = [zeros(1,20) ones(1,80) zeros(1,40)];

6. make a note of the average percent change in the Visual ROI during deep
breathing. Is the BOLD signal decrease caused by deep breathing larger
or smaller than the increase induced by visual stimulation?

Right-hand ROI:
1. open another instance of the file is-0-allegra-20002-20011003-163352-8mri.mnc
2. change the signal type to Percent signal
3. apply the Rhand ROI to this file
4. exclude the first three frames
5. enter the same design input matrix you just used for the visual ROI
6. make a note of the average percent change in the Right-hand ROI during
deep breathing. Is the breathing-related negative change in BOLD signal
the same size as the signal increase caused by the motor task? Compare
the average breathing-related changes in BOLD signal in visual and motor
cortices.
Grey and white matter ROI's:
Here, you will manually paint regions of interest in grey and white matter regions
that should not be affected by the visual and/or motor tasks. The purpose is to
compare grey and white matter signal changes during a global blood flow
change.
1. open yet another instance of the file is-0-allegra-20002-20011003163352-8-mri.mnc
2. right-click on the transverse view and select Copy this view to big
window
3. change the signal type to Percent signal
4. exclude the first three frames
5. enter the same design vector you used previously to depict the time
course of deep breathing
6. from the Tools->Region of Interest submenu, select Create ROI->by
manually painting it. Give it the name "Frontal".
7. Now you can paint an ROI on the current volume by clicking the middle
mouse button. Note painting a voxel does not force the triplanar display to
that location, but you can still use the left mouse button to move around in
the volume. Paint a region of interest of about 10 grey-matter voxels in
frontal cortex.
8. make a note of the average percent change in the frontal grey-matter ROI
during deep breathing. Repeat the above steps for a grey matter ROI in
parietal cortex, and a white matter ROI anywhere in the brain (call them
Parietal and WhiteMatter - or something; get about 10 voxels in each

region). Compare the breathing-induced signal changes in the three
regions of interest.

Responses to visual and sensorimotor stimulation during deep breathing
Now we'll look at the BOLD signal changes in the visual and right-hand ROI's
produced neuronal activation induced during a period of deep breathing. The
goal here is to see how the activation and breathing-associated responses
interact. If we cause neuronal activation against a BOLD signal baseline that has
been lowered by deep breathing, will the changes summate linearly? Is the
BOLD signal during activation independent of the baseline? Discuss possible
responses to these questions in your report.
Visual ROI:
1. open the file is-0-allegra-20002-20011003-163352-7-mri.mnc
(this file contains the scan with visual and sensorimotor activation
combined with deep breathing)
2. change the signal type to Percent signal
3. apply the Visual ROI to this file
4. now using Tools->Stimulation/Timing->Enter frames to exclude->as
MATLAB® expression exclude the first 23 frames and the last 40 (enter
Exclude=[1:23 101:140])
5. enter the design input matrix for visual/motor stimulation to obtain the
visually-evoked signal change against the decreased hypocapnic
baseline. Is this change the same size as the visually-evoked response
during normal breathing?
Right-hand ROI:
1. open another instance of the file is-0-allegra-20002-20011003-163352-7mri.mnc
2. change the signal type to Percent signal
3. apply the Rhand ROI to this file
4. again, using Tools->Stimulation/timing->Enter frames to exclude->as
MATLAB® expression exclude the first 23 frames and the last 40 (enter
Exclude=[1:23 101:140])
5. enter the design input matrix for visual/motor stimulation to obtain the
motor task-induced signal change against the decreased hypocapnic
baseline. Is this change the same size as the sensorimotor response
during normal breathing?
6. prepare a brief and qualitative description of the interaction between the
breathing and activation-related signal changes (visual and motor)

Examination of physiological signals
During the experimental session, we also recorded several physiological signals
from the subject. These included heart rate, end-tidal CO2 (a measure of CO2 in
the arterial blood), and tidal volume. Now you will examine these recordings,
which are contained in Microsoft Excel files, and see how they correspond to the
observed MR signals.
1. open another instance of the file is-0-allegra-20002-20011003-163352-8mri.mnc
(this run is the deep breathing-only data)
2. change the signal type to Percent signal
3. exclude the first three frames
4. apply the Rhand ROI to this file
5. from the Tools->Stimulation/timing menu, select Enter design
matrix/vector->from Excel file
6. select the file Run8-ETCO2.xls to see the decrease in end-tidal CO2
during deep breathing; note the correspondence to the period of BOLD
signal decrease
7. to see the plot of end-tidal CO2 with axis scaling, execute the following
MATLAB® commands:
ETCO2 = xlsread('Run8-ETCO2.xls');
plot(ETCO2)
xlabel('frame')
ylabel('End-tidal CO2 (mmHg)')
make a note of the initial "baseline" value, and the minimum value at the
end of the period of deep breathing (around the 100th frame); does endtidal CO2 return to baseline by the end of the final two minute recovery
period?

8. now read in the design vector from the file Run8-TidalVolume.xls to see
changes in breathing depth during the scan. You can also load Run8HeartRate to see heart rate during the scan.
9. repeat the steps above for the Visual ROI, a frontal grey-matter ROI, and
a white matter ROI.
10. prepare a brief and qualitative description of the relationship between the
different physiological parameters measured and the BOLD signal. Does
this relationship vary across the brain?

Magnetic resonance angiography
At the end of the session, we acquired an MR angiogram. This scan shows blood
vessels as regions of higher intensity, and can be used to identify vascular
responses in BOLD activation experiments. Series number 12 (is-0-allegra20002-20011003-163352-12-mri.mnc) is the angiogram - load the file in Dview
and adjust the window levels to obtain good depiction of the vasculature. You
can use the vascular images to position the cursor, then select an EPI series to
see the BOLD signal at the approximate location of the vessel. Note that, with a
512x512x90 scan matrix, this file is huge and will take a long time to load. It's
also important to realize that not all blood vessels show up strongly on such
angiograms. Veins carrying blood which has spent a lot of time in the imaged
volume may be very faint since the inflow enhancement effect diminishes after
repeated RF excitations.
Lab report
Carry out the above exercises, and submit a concise report consisting of
the observations you were directed to make above. You can print the
Dview display window under the File menu, so feel free to make use of
annotated printouts like this to describe your findings.
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